Ottokar campaign not Advancing past first mission

I’m not sure how to ask for mod support but the Ottokar mod campaign is supposed to be five scenarios in a campaign and I’ve beaten it twice, once before I got Dawn of the Dukes, and once after, and it won’t unlock the second mission after I beat the first, Interregnum. I’m not playing with any data mods, all mods are simply cosmetic

I don’t know what’s going on and I’m not sure who or where to ask for help. I really enjoyed the first mission I’d like to play the rest. .Any help is appreciated.

If you have loaded from a savegame, custom campaigns won’t progress after beating an scenario. It’s a known bug. You need to use cheats


No, I started a whole new game from scratch, re-enabled Ottokar and it still didn’t advance. They only thing I didn’t do was uninstall it and install it again since getting dawn of the dukes.

But for the save gave and gave I launched since getting dawn of the dukes, what is the cheat I should use to advance to mission 2? And should I use it in mission one or in the Ottokar campaign map or where?

The cheat code is “i r winner”. You will need to use it after completing a game off a save you loaded, because save games don’t count for purposes of custom campaign completion (it’s a known bug). Just start the level you are stuck on again and put in the code.


Holy crap that worked! and I guess that’s general advice…beat the scenario right, the I r winner to advance. Does that work campaigns? I’m almost at the point it doesn’t matte, but I’m just curious.

And if I got your ear, I posted a mod request down the way with no responses, not asking for you to consider it, only if I could have asked it better/more clearly. I’m autistic and communication is not always my forte.

1 Like

It would work for official campaigns, but they don’t have the same save and load bug. It also isn’t worth the risk, because I’ve reas bug reports where people cheat the level to win, which doesn’t give the medal, and then they can’t get it, even when they do it properly. It might be fixed, I may even have imagined it possibly (and assumed it’s a memory), but it isn’t worth the risk. It’s also not fulfilling at all having to cheat to win.

You mean the healing farms thing? I might be able to look into putting something together for you, give me a day or two, I’ll see if I can do it without too much work.

1 Like

Hey thanks for considering it! It leaves me the other problem of figuring out how to take screenshots in AOE 2 and in genral with a prgram that gives save promts so I gave give it a file name and a file location of my choosing.

I have a save file of the second Dravidian Campaign where I after I had a bad taste in my mouth for the no rest for the wicked achiement I went back and tried to rebuild the old capital Redena Cola’s (the campaign protag) father Rajaraja had leveled and left in ruin. I cleared the jungle, I tried to create a beautiful city within the in game building options. Show that Renda is despite the Evil Empire vibes only headed for 2/3 Evil Emperor.

I kinda want to show if off if I can get a picture. Roleplay for the win!

The best way to screenshot I’ve found, is to open snip and sketch, and then use that, because it will save the screenshot in the snip and sketch browser for you to deal with.

1 Like

Cool, I didn’t even know that feature existed! I’m try that as dinner cools!

I’ve almost finished your mod for you, just testing to find a realistic default grass texture, but I’ll include several you can choose from.

1 Like

Do you know how to open your local mod directory?

Ok here is your mod:

The forums can be a bit irritating at times, like how they don’t let me upload zips directly, but this should work. To get it, download the zip, unzip it, and drop the whole thing into your local mod directory. Then check the mod is enabled using the ingame mod manager, and then restart the game for it to take effect. In terms of the actual effect used, I think I’ve picked a good grass texture that fits with most terrains, but if you don’t like it, I’ve included about 5 alternatives in the mod. Just open the folder, click through all the sub folders, and in the last one, there will be a number of .dds images. These can be viewed using If there is one you like more than the current one, make a copy of it, and the original, and then change the file name to g_fm2, keeping the .dds extension.

1 Like

It says the link code is invalid. see the first time I clicked on it I had to input my email address then it sent me a new thing to check and I think a new download would work.

It might do better to upload to the AOE site here but I’m not gonna tell you what to do on that. Just if you’re gonna do the Filehosting thing, I guess I need a new download code. I apologize for that, although given the email requirement I don’t think that’s my fault. I think.

Also says it’s parked by and looks like it’s for sale.

Here’s the download link:
Paint.NET - Download
Click on the DotPDN thing on the right.
Try this link to download it: | Download | Healing

I can’t, the forum doesn’t let you upload a lot of file types, .zip included.

1 Like

It’s going through. I’ll check it and see what it does!

Well I tried it, it was the same stony ground. Leeme try and use…

See that ground right by the TC on the right side? That’s the ground I keep getting. I even disabled all mods but yours, Is this the terrain you selected? Cause I wanted one of the grass variants, probably grass2 from the scenario editor.

WAIT! See the what you intended. So given this is for the Fallout scenario and that scenario makes ZERO graphical edits, and the stony ground under the farm remains is the exact same in the Ottokar scenario (which makes a great place to deploy the mobile TCs in the first mission).

I’ll try and make sure I got rid of everything but because all I run is graphics mods (achievements) nothing should have stood in the way of this working. It’s certainly selectable in the mods folder. So there’s that.

I’ll give you step by step instructions on how to recreate the mod so you can be sure it works.

  1. Open your local mod directory, C:\Users\JohnSmith\Games\Age of Empires 2 DE\A large number\mods\local
  2. Create a new mod in that directory, call it whatever you want.
  3. Inside that mod, create the following sub folders, so that your final path looks like this: Your_Mod_Name > resources > _common > terrain > textures > 2x
  4. Now, open another file explorer window, press Windows + E to do this easily.
  5. In the new window, go to C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\resources_common\terrain\textures\2x
  6. Use Paint.Net to decide on the texture you want. If you want grass 2 from the editor, you need the file called I think.
  7. Copy the .dds file you chose into the mod folder you just made.
  8. Rename it to
  9. Check your mod is enabled and start the game again.
  10. If it still isn’t working, copy paste the file in the game files to save it, and then copy your replacement in and rename it. This will directly replace it in the game files, which shouldn’t be needed, but if it doesn’t work, you may need to.
1 Like

OK I’ll try that. Maybe not tonight, it’s almost midnight but tomorrow maybe. Thank you man!

OK I got the walk through and it worked. The problem is that you were reskinning the “dead farm” and not the terrain under the farms which is rock or technically “g_rck” which is why I definitely want a mod I can swap out pretty much just for the Fallout mod.

Would you be willing to work with me with other reskin projects? Cause I have the basics but units and buildings have their own problems, and probably best practices in terms of swaps. And probably needs a new threat too.