Regarding guard/imperial upgrades (and a related bug)

In the original game guard/imperial upgrades share the same unit appearance (imperial upgrade does not change it). Thus age II units have 3 models and later units have 2 models, generally.
In DE, however, there seem to be a slight difference in color schemes between guard and imperial upgrade, but barely noticeable unless zoomed in (I don’t have a screenshot at hand).
I think this is intentional, but why not make it more obvious?

1 Like

And I found this problem from a Chinese forum: A huge thank to the user who found it.

Say for fortress age units, we had 2 tiers of models in the original game, with tier 1 for veteran and tier 2 for guard/imperial.
Now that we have three tiers: tier 1 for veteran, tier 2 for guard and tier 3 for imperial.
The problem is: the imperial version of a royal guard unit does not change the model. The results are as follows. Note all the units are in the imperial tier:

This is the shared imperial halberdier (tier 3 model)
This is the imperial royal guard halberdier for the Dutch (still tier 2 model, note the belt is gone)

This is the shared imperial dragoon (tier 3 model)

This is the imperial royal guard dragoon for the Portuguese (still tier 2 model, note the tassel)

An earlier post seem to refer to a very same problem, this time with skirmishers (different color scheme between tier 2 and 3 model, but imperial royal guard does not change the model)

I’ve done some easy modding and I believe this can be fixed by changing a few lines in the imperial upgrade technology.

As I’ve mentioned in another post, being able to progress in time is one of the most enjoyable parts of the game. Lacking progressions through upgrading would be frustrating, especially when you’re having an elite unit looking less advanced than the commonplace ones.

Thanks for the report. I was here to report the same for the portuguese jinetes that look like veteran dragon.

Hope the developers notice this

This problem is still remaining to be solved, or is it even getting worse? I used to think that jinetes is the only dragoon that doesn’t have guard status looking, but I found today that even dragoons from other civs don’t have guard looking now!

1 Like

I tried several times in a similar thread to notice this bug. They answered that it has been tracked, but is still unsolved. By the way, the ports are a civilization that became important in the last dlc, so I really don’t get why this bug is still here.

1 Like