Renamed units unrenamed after garrison

Hey !

I have numerous custom characters in my mods. Basically I just rename some units from the vanilla game at the very begining of each scenario through a trigger.

But there’s this : whenever they enter anywhere (tower, castel, boat…) they don’t keep their custom name when they get out. It’s not THAT awful when it’s a standard unit, but when I use a hero as raw character it’s really disturbing. Player are like “who’s this guy?”.
Any solution to that problem ?

1 Like

@BassiAoC Maybe you know a fix for this? :slightly_smiling_face:

More info is needed.
What effect did you use to rename the units? And what units are renamed?

Do you need all of the units ? I do it with a lot of them, I create mercenary companies with special units from all the civilisations.

For instance I rename a monk “Frère Jean” with the effect “change the name of the object” (something like that, sorry I use the French version of the game) but when my monk step in a boat, he’s named “monk” back again. I only use it on specific units (not the whole type of unit).

You can see it happening in the 3 scenarios of “Chronicques Gargantuines” my mods.

I can make you a list of the units involved if you need but I’m almost sure it happens to all of them.

I tried myself and I cannot reproduce this issue.

Same, tried garrison/ungarrison with ‘Jean Frère’ renamed Bui Bi as well as Pope Leo I in:

  • keep
  • castle
  • tc
  • transport ship
  • bombard tower
  • fire tower

The only thing I can think of is maybe a localization issue? But then again, I think I encountered stuff like this when I used to design for HD. Maybe it’s a …relic :stuck_out_tongue:

AH for some reason I thought it was an issue for every character. But I can clearly remember the RELIC now. Yes, it’s the relic!

I’m sorry I didn’t have the time to recheck my allegations.

1 Like

See a post I wrote for a similar issue:

1 Like