Signing into Multiplayer Services

Game Version:

  • Build (34793)
  • Platform (Microsoft Store)

Failure of “Signing into Multiplayer Services”

Reproduction Steps:

  1. Click Multiplayer Game Button
  2. See “Signing into Multiplayer Services” Message.

image

1 Like

Please check in MS store if latest updates for Gameservices and Xbox Game Bar are installed. If they are up to date you could try to sign out from them first and then launch AOE II DE again and try the multiplayer. Also please make sure that you have run a graphics performance test below options.

There is no method I haven’t tried for 9 days.
Registers, cmd, vpn, router, fix buton, update, uninstall/install, antivirus, firewall, toredo, nat, etc…

I’ve been playing before.
This problem started with last update…

Okay. It would be helpful if you could share a link to the latest log file which is stored below folder: C:\Users\<YourUserName>\Games\Age of Empires 2 DE\logs

2020.02.03-19.05.56.txt

Initializing Time System
Initializing Command Line
Constant Logging is OFF
Verbose Logging is OFF
Startup is being logged
Age of Empires II DE start at 2020-02-03T16:05:56.278Z
Build version: 101.101.34793.0
Build config: Final XBL D3D11, built on GPSBUILD014, at 2020-01-22T14:56:04
DirectX Setup is being logged
Initializing Performance Profiler
Gathering System Information
Processor architecture: x64 (AMD or Intel) type 86/x64
Processor level 6, revision 19971
Number of processors = 4
Multi core processor #0, efficiency class 0, 1 groups
Processor group 0, affinity 0x3
L1 data cache: line size=64 bytes, size=32768 bytes, affinity=0x3, group=0
L1 instruction cache: line size=64 bytes, size=32768 bytes, affinity=0x3, group=0
L2 unified cache: line size=64 bytes, size=262144 bytes, affinity=0x3, group=0
L3 unified cache: line size=64 bytes, size=3145728 bytes, affinity=0xf, group=0
Multi core processor #1, efficiency class 0, 1 groups
Processor group 0, affinity 0xc
L1 data cache: line size=64 bytes, size=32768 bytes, affinity=0xc, group=0
L1 instruction cache: line size=64 bytes, size=32768 bytes, affinity=0xc, group=0
L2 unified cache: line size=64 bytes, size=262144 bytes, affinity=0xc, group=0
NUMA Node #0
Group max: 1, active groups: 1
Group #0, 4/4 active processors, affinity mask:0xf
Total physical memory is 8.000 GB
Maximum system memory: 7.901 GB currently available:5.077 GB
Primary display resolution is 1920x1080, desktop size is 1940x1100
Graphics Adapter Name: Intel® HD Graphics 520
Adapter LUID: 00000000:0000d359
Vendor: 32902 device ID:6422 subsys ID:487395395 rev:7
Dedicated VRAM: 128.00 MB
Dedicated system RAM: 0.00 MB
Shared RAM: 4045.54 MB
Battery level high - over 66%
Battery charge level is 84%
Battery saver is OFF
Benchmark quad write: 0.539500 milliseconds == 16682.11 MB/s
Benchmark fast write: 0.550000 milliseconds == 16363.64 MB/s
Benchmark slow write: 0.537967 milliseconds == 16729.66 MB/s
CPU rating: 18363.6, GPU rating: 128.0
Initializing Telemetry Manager
Initializing Time System
Setting Up Systems
Initializing Registry Options
Setting Program Defaults
Setting up main window
Initializing Reflect
Register Classes
Initializing Speech Synthesis
Initializing Achievement Manager
Initializing UI Widget Manager
Initializing Campaign File Type
Initializing SP Savegame File Type
Initializing MP Savegame File Type
Initializing Random Map File Type
Initializing Random Map Group Manager
Initializing Scenario File Type
Initializing Wwise Manager
Initializing Civilization
Initializing Error Handler
Initializing File System
Initializing DLC Manager
Initializing XBL System
Initializing Tool Manager
Initializing Mod Manager
Initializing Loggg System
Initializing Time System
Initializing UI System
Initializing Additional Options
Initializing Localization Manager
Initializing Font Manager
Initializing Terrain
Initializing Game Version Manager
Initializing FPS Control
Initializing Difficulty
Initializing Game Mode
Initializing Player Profile Manager
Initializing Update Manager
Initializing Panel System
Initializing Screen Stack
Initializing Sync Logger
Initializing Random Manager
Initializing Network speed Data
Active Launch Options: none
Initializing Game
Setting up graphics
Setting up mouse
Setting up screen
Setting up chat
Setting up comm handler
Setting version info: app = 34793 data = 0 mod = 0 version = 56950784
Setup mod manager
Setup post mod manager
Installing modded languages
Opening resource packages
Setting up palettes
Setting up shapes
Setting up save map area
Setting up sound system
Setting up screen resolution
Available resolutions:1920x1080, 1680x1050, 1600x900, 1440x900, 1400x1050, 1366x768, 1360x768, 1280x1024, 1280x960, 1280x800, 1280x768, 1280x720, 1152x864, 1024x768
Recommended settings:
resolution: 1920 x 1080
downscale percentage = 100
high-resolution assets = YES
antialiasing = NO
fog = NO, animatedFogBorder = NO
edge-blur = NO
bloom = NO
vsync = NO
File System Ready
Launching intro video AOEIIDE_TITLEVIDEO
Setting up video system
Opening video
Setting up interface messages
Loading player profile
Setting up hotkeys
Total Initialization Time: 14699 ms
Running Game
Total Texture Load Time: 0 ms
Closing video
Flushing pending telemetry events
Terminating Game normally
Terminating UI Widget Manager
Terminating Network speed Data
Terminating Random Manager
Terminating Sync Logger
Terminating Screen Stack
Terminating Panel System
Terminating Update Manager
Terminating Player Profile Manager
Terminating Game Mode
Terminating Difficulty
Terminating FPS Control
Terminating Game Version Manager
Terminating Terrain
Terminating Font Manager
Terminating Localization Manager
Terminating Additional Options
Terminating UI System
Terminating Time System
Terminating Loggg System
Terminating Mod Manager
Terminating Tool Manager
Terminating XBL System
Terminating DLC Manager
Terminating File System
Terminating Error Handler
Terminating Scenario File Type
Terminating Random Map Group Manager
Terminating Random Map File Type
Terminating MP Savegame File Type
Terminating SP Savegame File Type
Terminating Campaign File Type
Terminating Civilization
Terminating Wwise Manager
Terminating Speech Synthesis
Terminating Achievement Manager
Terminating Command Line
Terminating Reflect
Terminating Registry Options
Exiting with code 0

////////////////////////////////////////

Main.txt

[Main] : BaseGame constructor 1
[Main] : BaseGame constructor Before OpenFileById()
[Main] : BaseGame constructor After OpenFileById()
[Main] : BaseGame constructor 3
[Main] : BaseGame constructor 4
[Main] : BaseGame constructor 6
[Main] : BaseGame constructor 7
[Main] : BaseGame constructor 8
[Main] : BaseGame constructor done
[Main] : Game constructor 1
[Main] : Game constructor 2
[Main] : PreModManagerInit 1
[Main] : PreModManagerInit 2
[Main] : PreModManagerInit 2
[Main] : setup_main_window_internal
[Main] : …success! About to setup graphics…
[Main] : …success! About to setup mouse…
[Main] : …success! About to setup cursors…
[Main] : …success! About to setup blank screen…
[Main] : …success! About to setup chat…
[Main] : …success! About to setup communications handler…
[Main] : Game::install modded languages
[Main] : Game::open resource packages
[Main] : BaseGame::GameSetupPostModManagerInit() enter
[Main] : palettes
[Main] : shapes
[Main] : map save area
[Main] : sound system
[Main] : .oO Wwise Audio - Init Oo.
[Main] : .oO Wwise Audio - Init Finished Oo.
[Main] : BaseGame::GameSetupPostModManagerInit() succeeded
[Main] :
Play intro video AOEIIDE_TITLEVIDEO…
[Main] : resolveMovieFileName… AOEIIDE_TITLEVIDEO
[Main] : post resolveMovieFileName… C:\Program Files\WindowsApps\Microsoft.MSPhoenix_101.101.34793.0_x64__8wekyb3d8bbwe\Game\resources_common\movies\aoeiide_titlevideo.wmv
[Main] : About to setup video player…
[Main] : Creating DShowPlayer…
[Main] : …success!
[Main] : …success!
[Main] : Opening video…
[Main] : …success!
[Main] : set_interface_messages…
[Main] : … done set_interface_messages
[Main] :
About to load player profile (player.nfp)…
[Main] : …finished with player profile.
[Main] : Game::setup() before hotkeys
[Main] : Game::setup() after hotkeys
[Main] : VideoPlayer shutting down. Advance to main menu…
[Main] : endMovieFunction complete
[Main] : .oO Wwise Audio - Begin Shutdown Oo.
[Main] : .oO Wwise Audio - Shutdown Complete Oo.
[Main] : exiting
///////////////////////////////////////
SlowLog_2020.02.03-1905.58.txt
SlowLog Created

SlowLog Destroyed

Did you find any solution? The same issue happened to me after the May update. Reinstalling and uninstalling the game did not help. Also reinstalled Steam. Did not help. Other steam games work fine, including Age of Empires 2013

Here’s a detailed description of the problem that I am having. Along with some screenshots. Hoping someone from the support team can help. Haven’t been able to play the game since the last update at all.

Issue: “Failed to connect to multiplayer services” error. When I launch the game, the initial menu screen says “Sign into multiplayer services”. When I click that, I keep getting this error message no matter how many times I try. I am signed into my XBox live profile, but that does not help. Trying to sign into multiplayer services repeatedly leads to the same error. Game was working just fine until May 27th Update but have not been able to sign in a single time since then. June 2nd / 3rd Hotfix did not help.
Other games on Steam are working fine (including Age of Empires 2013).

XBox networking diagnostic: When I boot my computer up and run Xbox Networking diagnostic, initially I get the “Teredo not qualified” error, but that resolves itself in a few minutes to say NAT: Moderate, Server: Connected. Regardless of the status of the diagnostic, I cannot connect to multiplayer sercices

System: AOE2 DE downloaded via Steam. Running on a windows 10 system.Have not made any recent changes to my firewall or antivirus settings or my internet router.

Xbox networking diagnostic 2

1 Like

Do you also have the Xbox Companion-console installed?

If not search in MS store for updates, even sign out from MS store and search for updates again.

If it is installed, try signing out from Xbox Companion-console too before launching AOE II DE from Steam again.

Did you also try launching AOE II DE as administrator, maybe you missed the UAC popup for the dependency check.

Thank you PCS70. I had the Xbox Companion Console installed already. I re-downloaded from MS store to make sure i have the latest version. Signing out from Xbox Companion did not make any difference.

I tried to run AOE2DE as an administrator (by going into Steamapps / common / AOE2DE and right clicking the app, selecting run as administrator). It gives me an error message saying app was launched outside steam, and it tries to relaunch it from inside steam. Is there a different way to launch this as an administrator?

I have never had the “UAC popup for dependency check”. Not sure what that is.

Hi @GMEvangelos, the recent hotfix did not help my issues of signing into multiplayer services. I have posted a detailed description here. Hoping you can help since this problem only came up after the May 27th update.

I have that every time with the MS store version, but that could be different with the Steam version indeed.
Do you sign in on your device with a MS connected account or normal local user account?

Currently running 3 Xbox apps, you can also install the beta of Xbox-Companion and they offer now a third Xbox app and of course the Xbox Insider Hub, so that makes 4 actually. Oh, I forgot the Xbox Game Bar and Xbox Games services, so that makes 6 of them. :slight_smile:

Never mind, more fresh updates are coming in at the moment. Posted a screenshot so you can compare regarding MS store updates.

I want to confirm that you worked through all of the steps here to see if they help with the issue:

And to clarify: are you able to sign out of Xbox Live and access the multiplayer services? Would you mind including a copy of your dxdiag so we can see if there’s anything potentially interfering with your connection?

Thank you!

@GMEvangelos; Thank you for the response. Yes, I tried the steps listed there. I have whitelisted AOE2 DE and Steam on my firewall and anti-virus, plus everything was working fine before the update so dont think there are any issues with that.

Also, just to clarify I can sign into Xbox Live just fine - both in my Xbox Companion Console as well as from inside the AOE2 DE app. However, I cannot connect to multiplayer services regardless of whether I am signed out or signed into Xbox Live.

Can you give me instructions on how to share the Dxdiag results with you? I tried running dxdiag and copy pasting results here, but it is too many characters to post and I get an error message.

@GMEvangelos: Figured out how to upload DxDiag files. Attached here. Thank you for your help. DxDiag.txt (140.6 KB)

1 Like

@AllanMcPhrust I’ve private messaged you with a request for additional information. Please let me know if you can help us dig into this issue.

Did you update windows with the may patch?

I am not sure. I have Windows 10 enterprise version. My guess is that it’s not updated in the last month or two. Do you think updating to latest version will help?

Try it, maybe it can help.

@AllanMcPhrust I am having the exact same problem you described above - were you able to resolve your issue? I have uninstalled and reinstalled, disabled firewall/antivirus, signed in/out of xbox live, made sure everything is up to date. Still not luck. I can play multiplayer on AoE2 2013 edition - just not DE.

@EliteBlade117: No solutions yet. I shared some logs with the support team and am waiting to hear back. Will post here if I find a solution. Good luck!