Units Disappear with Enhanced Graphics Pack

When starting a new game with UHD on all the units are gone and unselectable.
I have reinstalled multiple times and tried this fix that I found on another post:

  • Uninstall game
  • Reinstall game only (not HD pack)
  • Start game and start a random map
  • Exit game
  • Install HD pack

I have a 3900x cpu
5700xt gpu
16gb of 3600 memory

If anyone knows of another fix please let me know.

Thanks

Game Version:

  • Build 101.101.34223
  • Platform Microsoft Store - gamepass

Issue:

Posting this for a friend of mine who is playing on a 4K screen. Sometimes units like the starting scout or villagers are invisible (can still be selected through shortcuts) and sometimes villagers are smaller than it should be. The issue does only occur if the enhanced graphic pack is enabled. See attached photo.

Reproduction Steps:

  1. Play on Microsoft Store
  2. Use a 4k monitor and resolution
  3. Enable the graphics pack

same problem, with cumans, only happens with their unique units havent tried the other nations :3rd_place_medal:

I apologize if this isn’t the place to post - new to the forums and bug reporting in general - but I am still having an issue with invisible villagers. Usually just while working on a resource. I tried to attach a 30 second clip from my last game where this was happening, but it will not allow this for new users. It’s been in every game I’ve played for some time now, and I didn’t see it on the “known issues” post for the Definitive Edition bugs.

My version is 101.101.34793.0 0 from the Windows 10 store.

Thanks!

Edit: Please see pic below, video was too large. Right above my mouse cursor there are 3 or 4 villagers on trees that are all invisible.

1 Like

Hi all, still having the same problem. AOE II DE has been displaying fine for me. However, after I install the Enhanced Graphics Pack, i can only see the terrain when beginning a Standard game. I can no longer see any villagers or the TC. The message which pops up is "System attempted to load an incorrectly-formatted asset; some assets will not display. "
I uninstalled and reinstalled the EGP, but no change.
What are the proper troubleshooting steps?
Thank you.

Hello everyone! I’ve re-escalated this issue to our team, but could use the following (additional) informationif you are still experiencing this issue:

Thanks for the report; I hope this helps!

Is to disable all mods you have, or update them as they don’t automatically update and reactive one by one checking each time on the single player if that same message promts out…

1 Like

Hi all, I have the same problem.
Version 101.101.37906.0 from MS Store.

See, there in nothing on the screen in the first training mission.

1 Like

Hello everyone! As mentioned by @RoomOfTheEvil earlier in this thread, it looks like the most common cause of this problem is when another mod is conflicting with the files added by the Enhanced Graphics Pack. For those of you recently experiencing this issue (@gbal3434 and @manupstairs1), it is recommended that you try disabling all of your mods, re-launching the game, and seeing whether you experience the same issue.

Let me know, and thank you for the reports!

1 Like

Thanks @GMEvangleos for your reply. Actually I don’t have any mods. And I reinstall multiple times.
Seems Enhanced Graphics Pack still can’t works.

2 Likes

Thanks for letting me know. Would you mind attaching (or using a file share to upload) the following files:

  • A copy of your dxdiag.
  • A screenshot of your graphics settings.

I will get those passed to the team so they can see what might be causing this issue.

Thanks again!

DxDiag.txt (95.3 KB)
Thanks @GMEvangelos ! I upload dxdiag and graphics settings . Could you please have a look?

1 Like

Looking at your dxdiag file: can you please ensure that you are using your dedicated graphics card to run the game? You can do so by following these steps:

  1. Navigate or search for the Graphics Settings system settings panel on your machine.
  2. Select Classic App from the drop-down menu.
  3. Click Browse.
  4. Select this file: C:Program Files (x86) > Steam > steamapps > common > Phoenix > AoE2DE_S.exe
  5. Click Add.
  6. Now go to Options and choose High Performance.
  7. Save the settings and re-launch the game.

If you’re already using the dedicated graphics card, please check that your on-board drivers are also up-to-date. You can find some other laptop troubleshooting steps here:

Let me know if any of those steps work for you, and thank you for passing this information my way! :slight_smile:

Thanks @GMEvangelos, I am also not using any mods. I downloaded from the MS Store, so the Steam-related instructions do not apply to me.
I went to Graphics Settings, chose Microsoft Store (instead of Classic App), selected AOE II DE and set performance to High. No difference

This issues still exists. It also happened to me and I dont use enhanced graphics.
In Membs stream he had invisible spears killing his enemy 11

https://clips.twitch.tv/ OnerousSpicyBubbleteaCorgiDerp

@GMEvangelos I updated AOE II DE through the Microsoft Store yesterday, and tried the Enhanced Graphics again. This is the new error that pops up.


@GMEvangelos this one too. Shows AOE II version too.

1 Like

Hmmm. This is, indeed, odd. Here are a few things to try and questions to answer:

  • Is your monitor plugged into your motherboard or into a video card port on your computer?
  • Have you updated your video drivers?
  • Have you tried re-downloading the Enhanced Graphics Pack?
  • Do you see the problem if you are NOT running the Enhanced Graphics Pack?

Please include a copy of your dxdiag if you continue to see issues, as that will help us diagnose the problem.

If I hear or think of anything else, I’ll let you know!