Waypoint incorrectly set after doing multiple actions in succession

:arrow_forward: GAME INFORMATION

  • BUILD #: 4#####
  • PLATFORM: Steam / Microsoft Store
  • OS: Windows 10 / Windows 7 / Mac / Linux

:arrow_forward: ISSUE EXPERIENCED

When playing the game and doing multiple actions successively, the waypoint for a group of buildings (most notably the town center) seems to change to a seemingly random location the map. This bug has been present for the last few months, and from what I’ve heard, typically only affects higher level players.

:arrow_forward: FREQUENCY OF ISSUE

  • 75-85% of the matches I play (FREQUENTLY)

:arrow_forward: REPRODUCTION STEPS

  1. Launch the game
  2. Assign control groups to some units.
  3. Switch between moving the units, jumping to the town center, and setting the town center waypoint.

:arrow_forward: IMAGE & ATTACHMENTS

I’ll update this post with links to top players’ streams/ my own games, where this is happening.

Why this is a problem?

Frequently myself and others find that because of this bug we are rallying our villagers into our enemy’s base or some random spot on the map…

8 Likes

I’m having the same issue and it happens more times, every single game. So tired of having vills randomly walking around the map. I think it usually happens when i spam hotkeys/group numbers or setting a gather point or scrolling around with the mouse… not sure but it’s so annoying.

Yep that happens to me also, exactly the same way when i set the waypoint and quickly switch to a group or i think even if i click quickly in the minimap, like if there is a delay in the waypoint action confirmation or something.

This terribly edited video shows the problem.

If you change to your town centres (and probabely other buildings) fast enough after you click. it sets the waypoint for the tcs instead of moving the military, even though you clicked when you had your military selected. You have to be pretty fast to do this so slower players wont notice and thats why viper struggles with it so much and daut well 11.

Anyways hope its helpfull
top right shows the mouse clicks btw.

3 Likes

This happens to me all the time. Needs to get fixed. ;(

2 Likes

Are you guys still having the same problem after the February update? I have even changed my mouse because I though I was missclicking the right click!!! I got an ergo mouse and the same issue keeps happening. Yes, the most critical thing is the towncenter moving the gathering point wherever the cursor is in the map. Super annoying bug indeed.

1 Like

I’ve been getting this a lot recently. My TC randomly sets the gather point to somewhere I didn’t set it too. Even does this in boar lures when using vils in TC to shoot the boar, which causes a lure fail obviously. I also saw a streamer complaining about it happening to him, so this must be quite commonplace, and urgently needs fixing because it completely stuffs your game up. It’s not a minor cosmetic or inconsequential bug.

3 Likes

I’m surprised that not many people have been reporting this extremely annoying bug. I have noticed that sometimes the gathering point gets in areas I have never explored or gone over with the mouse in the map before. The point always goes to an extreme of the map, never close.

1 Like

Well I think it really only becomes an issue when someone has a fast enough APM (so it doesn’t affect the average player). It would be nice to know whether the developers are actually aware of the issue. (Looking at you Mod Evangelos)

2 Likes

honestly, as a fast player this has happened to me A LOT but up until now i just assumed i misclicked something. i will check this when i can.

2 Likes

I guess I am too slow for reproducing this consistentially. And the maybe 10 times this occured to me I assumed I have misclicked 11

2 Likes

Thanks for reporting guys. I also thought I was misclicking with my new g305 (symmetrical mouse), which I replaced it with a Pawnage UC ergo, but the issue keeps happening. I’m 100% percent sure now it wasn’t a grip issue.

1 Like

I tried fixing the issue by changing the hotkey for setting the gathering point, but the issue is still there.

1 Like

I don’t know much about RTS games since I’ve always been mainly a FPS player, but I don’t recall ‘misclicking’, like ever. I did kill my teammates a couple of times, due to reaction times begin faster than IDing the enemy, but I would say it is very unlikely to click where we are not supposed to.

In RTS games, it is different than in FPS ones since there’s a lot more decision making, even when being a pro. Of course, there’s “techniques” that are always or most of the time used the same way, over and over unless an update changes the gameplay drastically or in a slight manner. I do think in RTS games it is even less frequent to make mistakes with the mouse unless it is like, super sensitive, but again, the more you do something, the less eager you are to make mistakes (unless you start acting like you own everything, and make mistakes again, but that’s something that doesn’t last long in my experience). Getting cocky in games is something that lasts shorter than a falling star in terms of raw, serious gameplay.

This is a bug. I’m 99,99% confident about it.

Hello,
it would be great if any of you could share additional details to when and how this bug occurs, because currently this didn’t happen in our tests. The best ofc would a video where this does happen.
Thx for any extra help!

2 Likes

Thanks for your attention ChristheCo. This happens to me at least one time in every rated game. I really haven’t been able to identify the trigger of the TC gathering point being set in a random area of the map. I could only tell that when performing multiple actions. I will try to make a video as suggested when I get some time.

2 Likes

Dear ChristheCo. As promised, I’m sending a video with the issue here. This time happened in an offline setup playing with AIs, but normally happens to me at least once in every game when playing online, vs or tg. When going quickly to the TC and buying villagers the TC sometimes change the gathering point to a random location in the map. I changed my mouse thinking that was the issue, but it is a bug. I also tried to solve it changing the hotkey for gathering point with no results.

2 Likes

Thanks for the vid. Makes it clearer to identify the issue. I hope for a fix! :grimacing:

1 Like

this seems like a different issue than what im experiencing.
in your case it seems like there was a right click on the minimap, and the sign for the gather point on the minimap was shown in delay which is why the mouse wasnt there, but the mouse definitely hovered over that point.

what I experience is that when raiding and quickly making vils, sometimes where i told my unit to go becomes my tc’s gather point.

1 Like

May look like a click, but indeed I didn’t click the minimap.

1 Like