AMD stuttering fixed in october 21 patch

So ladies and gentlemen - first I wanna thank GregRising alot for the help and effort he put in. We gathered some informations.

And it would be nice if someone of you guys could reproduce our stepps and test it - so we can see if the problems lies there.

You need to download DE Replay Manager - GitHub - gregstein/DE-Replays-Manager: Manage Age of Empires 2 Definitive Replays

Our target is to conform the two patches. The one without lagg and that one patch were the stutter begin.
At my system is was that the patch of 21 October 2020 runs smoothly. After that with the patch of 17 November 2020 the stutters start to appear

To make the Replay Manager run correct and able to downgrade - you need to install that here too

The Replay Managers has a downgrade function with were you able with your login data to downgrade AoE 2 DE. Ofc after that you can patch back with the steam function.

I always double check ingame - I tested if the benchmark is stuttering and if the game itself laggs. I tried with 4on4 Deathmatch mode (so its faster/more commands etc) with AI on very hard. So the AI is putting alot of effort into the game.
Ofc you can also test online but I wanted not to disturbe any more people - because I already did and dont want to destroy any more gaming expierence just because I have to test things.

So if you have some problems feel free to contact. I have already collected some expierence now. Would cool if one or two could reproduce my steps and confirm if our suspects will beconfirmed.

Message to the developers:
Please take a look at steamdb and compare 21 October 2020 with the latest version - something is strange. Its likely AoE2DE_s.exe because we have replaced /shaders/ and /wpfg/ with the ones from 21 October to no result.
Please investigate this. (21 October 2020, 31 January 2022)

Thx and have a nice evening


I have 2 AMD systems, one with polaris and one with rdna, not a single issue, but with rdna 1 and 2 their architecture works different, if the gpu isn’t stressed enough the clockspeeds go down to 0 like if it was turned off, during all the game session the clock speed is around or below 400 mhz with deeps to 0, obviously when going to 0 there is stutter.

For some friends with rdna2 gpu’s their workaround has been to load the GPU with another app running simultaneously to stress the gpu like streaming or recording the game.

The patch that was causing more gpu usage was the one that had to be reverted cause it was overheating some laptops or desktops with bad airflow or cooling, that patch removed the cap of the framerate so it was doable to achieve 300 fps in 1x1, that patch or option should be optional for those who aren’t on a low airflow device.

There was a trick with older amd drivers that enabling enhanced sync on radeon software it was removing the forced vsync, but it wasn’t steady, i tested it out and the benchmark score was so bad cause of massive fps drops, with newer drivers that bug has been removed but if there are still users using old drivers i wouldn’t recommend having enhanced sync on cause even if you see more fps it has even lower score than with vsync meaning less stability and performance.

Let me point out that the Author of this post has stutter freezes that are only noticeable if the game drags to late game or if you play against 7 extreme difficulty AI. The game starts freezing or all the moving units/objects ingame freeze for a second or more repeatedly.

It would be appreciated if the author records and posts a video of the stuttering to give a clear picture.


a user from reddit Davecasa has a fix for CPU AMDs

Source from r/aoe2

Full pink to the discussion thread on Reddit:

1 Like

But is this issue connected to the one everyone is now having? Not sure. You say you had problems since 15 months ago. How do we know its the same problem that only started yesterday for most of us?

Good question! We have downgraded AoE2 DE patch by patch (from latest to backward) and the issue stopped occurring in 21 October 2020 patch. Is it happening to everyone or just this AMD series? We can’t confirm that until user engage in this thread. One thing for sure in the past few months, We have had a lot of AMD “GPU” users in our reddit r/aoe2 complaining about lag and stutter besides a few others that got in touch with me through discord with the same complain.
That brings us here with this finding that hopefully will be tested by AMD users and investigated by developers.

1 Like

No it’s a separate issue that some users of amd gpus have. It’s not all amd users though. However afaik no one could really explain so far what’s the reason for that and why some people have it while others don’t despite using same gpu models and identical drivers. Anyways this has nothing to do with performance problems of recent patch.

1 Like

Greg did you read this thread already?

Waht do you mean? I think this user found the problem with the AMD cards - makes alot of sense what hes writing.

The AMD stuttering gets fixed by my fix. That said, the recent patch added on top some bad performance issues, and this time its not just AMD users.

I would suggest going backward with the patch.

this has nothing to do with your fix, but many people have it.

It fixed both issues (fps drop/stuttering and frame time delay). I had the frame delay before too.

I also enabled smart access memory.

But i must admit that the time frame delay - i also played around with the internal monitor settings using a 3rd party software that i do not remember the name.

This happens in 1v1’s as well for me. So it’s not just when the game is running heavy.

Well some users here clearly are spinning a different narrative. They even got this pinned to the aoe2 reddit, misleading all the users/players that this issue is the same one that they are all experiencing.

We are not misleading - these users are just not able to read correctly and you know what it is their problem. I have my own. For decades I’m not able to play and enjoy this game. Since release the time period were I was not able to play is larger then the playable period. Even with different system.
I’m sorry that the masses now expierence this issue - but here is nothing misleading. This topic is worth to pinned there because I’m not the only one that can’t play for that hugh amount of time.
1 Day after patch game is not working everyone is going wild - image how you would feel if it would be months or a year.

Yesterday evening - patch with FPS limiter got released. I played a game 4on4 DM with bots - had no lag (after I put FPS to unlimited). Was so exited - screamed for joy - unbelievable - today - the hard truth hit my again. I tried online - stutters returned. Tested it offline again - stutters laggs after sometime. Will test some more but only half-assed - mentaly I already gave up.

I still had the feeling that FPS limiter had some impact on this whole problem. This one game made me believe. Can people with AMD GPUs like 6600 XT say how their game is running now?
Maybe we could find a way to turn off this eco/energy save technology from amd for AoE 2 DE? So that the card runs fully when playing and not going into sleep mode.

Hello boys and girls

After a long time I tried some AoE again (was testing a different PCI slot - 4.0 → 3.0 - didnt made a difference)and I noticed somethings. There are some points and a question I would like to add and ask.

First off all - I noticed when you freshly start the game. In the first game you play is takes some time after lagg appears (if you do benchmark first - benchmark should run without stutters). After a time stutters begin. When you start a second game without restarting AoE it laggs from the beginning. Third game the same.
Can someone confirm my observation?

Second thing is I noticed. The most heavly stuttering/laggs happen when you place farms.
Can someone confirm?

1 Like

Hello ladies and gentlemen
Small update. I remeberd I had my old RX 470 8 GB in the basement. So I tried it and it works fine now. Can play AoE 2 without sutters or issues. My RX 6600 XT is chilling here in the meanwhile until problem is fixed.
Bye have a nice day