How to publish a scenario mod? I tried everything

I have a simple .aoe2scenario file i’m trying to upload but I can’t get it to download in the game client in either Steam version or Windows store version.

I tried zipping the scenario file only, and it ended up downloading but the directory folder only contained the scenario and the json file. When that happened the mod manager listed the mod with a red exclamation mark instead of a green checkmark. The only way to get this mod to work was by manually adding the folders resources_common\scenario to the directory and putting the .aoe2scenario file inside them. That would turn the red exclamation mark into a green checkbox and the scenario could be loaded.

The problem is that if I tried to upload the zipped mod including these folders the mod doesn’t download properly and the directory folder ends up only containing the .json file and nothing else.

This is driving me crazy, I tried every other combination as well,
uploading only 2 folders _common\scenario\ then the aoe2scenario file inside.
uploading only 1 folder \scenario\ with aoe2scenario file
uploading with and without the .json file (which is a file that seems to be created automatically when uploading).
uploading with and without _preview-icon.jpg in the root of the zipped file,
etc,

every other combination results in the subscribed mod to be stuck downloading forever in the client, both steam and windows store version.

I tried assembling the mod properly locally and using the “import local mods” button in the mod manager in-game, it never found anything.

I tried the update mode button on published mods under the ‘My Mods’ tab in-game and but it never allowed me to choose the folder. I could edit the description and title but I couldn’t click on or tab to the folder selection.

Sometimes the folder would say (NONE) and trying to update the mod would result in it failing saying “missing files”

and other times the folder option would be blank and updating would result in it failing saying “Failed to create zip”, running the game as Admin didn’t solve this.

This is seriously driving me up a wall, i’ve seen other people upload scenarios but I just can’t figure out how they did it, their file layout is no different than mine but for some reason theirs downloads with no problem, including the folders \resources_common\scenario and the .aoe2scenario file inside, exactly the same way I tried uploading my Zip, many times, I can’t understand why it’s working for others and not me.

Any help from someone who successfully uploaded a scenario? PLEASE and thanks

Is it even supported to zip mod files like that? I thought, that mod files need to exactly mimic game files structure. Have other authors used zipping successfully?

Well when you upload a mod it specifically states:
ZIP FILE UPLOAD
Attach one compressed file in .ZIP file format (500mb max). Note: only game generated files and .txt files (e.g. readme.txt) are allowed in the zip.

so that’s exactly what I did.

There are people out there who have managed to upload scenario mods that download successfully, i just wish one of them would chime in with some guidance. There are tons of other scenario mods that DON’T download successfully so I know i’m not the only one experiencing this issue.

There are just no guides or documentations on how exactly to do this.

1 Like

Make sure to check the zip file before uploading, verify that the only structure inside is “resources\_common\scenario”

If inside it is “yourmodname\resources\_common\scenario”, it won’t work.
if inside it is “_common\scenario”, it won’t work

I’ve seen uploading a zip work for “resources\en\sound\taunt”
Haven’t verified scenario works the same but I’m sure it does

Sorry I just noticed that the forums post automatically removed the “\” symbol before “_common” in my original post, must be some HTML thing, anyway what you’re suggesting is exactly what I tried, many times.

The exact folder structure inside “MyModName.Zip” is: resources\ _common\scenario and inside that ‘scenario’ folder is my mod file, ‘ScenarioName.aoe2scenario’ (copied directly from my personal game folder). So that’s 3 folders and one game file inside the ZIP.

Like I said in my original post, this is exactly the file structure that allows the game to recognize and load the mod properly when I manually copy the files to my directory. It works perfectly like that, the problem is that when I try to ZIP said files and upload it as such, it simply won’t download after subscribing. It gets stuck forever with the downloading icon (a spinning circle with dotted lines). The file size is tiny, like 24KB, shouldn’t take more than a second to download, if I am unable to download the mod on Steam AND Windows Store, I doubt others will be able to.

I appreciate the reply though

I don’t suppose its a super long file name is it? I had trouble with files over 80 characters long.
I also had trouble posting updates, could not get the files to change. I had to resubmit any updates as a new mod, but I think it had more to do with my mod being over 200mb and 894 files.
But if your file name is short, and posting as a new mod still doesn’t work for you, I’m out of ideas. I doubt a read only attribute would affect anything but maybe check that too.

Nope, less than 30 characters and file has full permissions.

I’m starting to think my games is just bugged and doesn’t download Mods properly. Maybe my mod works fine for other users, I remember someone actually liked my mod at one point before I deleted and reuploaded because it wouldn’t work for me.

I’ve seen support recommend deleting the mods folder in c:\users\x\games\age of empires\mods for some technical issues. maybe try that

THANK YOU!!! FINALLY, I got it working!

You answer wasn’t exactly the right but it helped me find the solution anyway. Turns out I was onto something before in my first post

I tried assembling the mod properly locally and using the “import local mods” button in the mod manager in-game, it never found anything.

So I read your suggestion and went to find and delete my mods folder in c:\users\x\games\Age of Empires 2 DE\mods\ and I noticed that inside were 2 different folders, one from my Steam version of the game and another for my Windows store version of the game. I did try deleting the mods folder, in every version of the game, but it didn’t help.

But that’s when I realized that my original attempt to “assemble the mod properly locally” probably wasn’t recognized by the game client because I put the files in the Steam version game folders and tried to load it through the Windows store version… or vice versa… idk, I never thought to check that before.

So I still can’t get the mod to work when I upload it directly through this website BUT when I paste the games into the correct local folder, so destination:

C:\Users\USERNAME\Games\Age of Empires 2 DE\GAMEFOLDERNUMBER\mods\local

and inside the local folder is:

\MyModName\resources\ _common\scenario\ScenarioName.aoe2scenario**

then FINALLY will the game be able to recognize the files when I press the “Import Local Mods” button(under the “My Mods” tab of the in-game Mod Manager)

After that I could see the name of the ‘MyModName folder’ as a mod in the list, it had a black X mark to the left of it this time, and the Publish Mod button appeared as an option when selected. From there I could enter my description, titles, upload the preview icon and press the Publish Now. Mod mod was zipped and uploaded successfully through the game client and then I download the mod through the Steam and Windows store version of the game without issue.

SOLUTION TL:DR
If the mod doesn’t download for you when you upload it to the website, try putting it your mods\local\ folder and using the in-game Mod Manger to import and publish the mod.

2 Likes

cool, I hadn’t considered users having a store version and a steam version at the same time.
Glad you got it :mage:
I’m not sure I’ve ever had any luck uploading via the website so you’re not alone there.

What folders exactly? I mean, we all have 2 folders in there, local and subscribed, but that is default regardless of where you bought it.

How to Upload via ageofempires.com
Make sure our zip folder starts with ‘resources’ as the folder name. Within resources should be ‘_common’ and within that should be ‘scenario’. Finally within ‘scenario’ should be your map. Please see this image to see what I mean. If you zip the ‘resource’ folder after building it that structure, it should work. Let me know.

Screenshot here

I have finished documenting both ways of Submitting Mods for DE. Via Website or from within the Game. Please take a look here:

1 Like