[Mod] Historical Units and Architecture

Very odd, since I don’t have any non-English letters or characters in my name. Oh well, I’ll just keep trying and see if it’ll work one of these times cause this mod looks really cool.

Somebody on steam thread of this mod recently asked for a link to manual installation. You may use the same. Here it is: https://drive.google.com/file/d/1LYJDQW8XYNI0ANR9bp58L8wjSYe3OCdJ/view

Finally got it to work. It pretty much worked on it’s own, I didn’t do anything different. Guess it was just computer gods smiling on me or something. Thank you for the help =D

Does this work with the Visible Corpses mod ?

(I think it should, but want to make sure)

Aren’t they UU? They have a unique model already.

Yes it should work with that mod.

With this mod the Konniks get a different model for Elite version from the Regular version.

It should work perfectly, unless this mod changes decay graphics files.
In that case you get either:

  1. Mismatch between normal unit graphics and decay graphics (if this mod has lower priority in mod manager)
  2. Normal quick decay (if this mod has higher priority in mod manager)
1 Like

do you know why I don’t display mods ?

The mod manager didn’t download the mods that’s why it is that red exclamation sign.

and what to do that would load ? :disappointed_relieved:

It is probably a bug in the game itself:

  1. If the game is unable to connect to its download server of mods then it won’t be able to download the mods. Try using some VPN or other internet IPs while running the game in case your IP is blocking it.
  2. I heard there is some problem for users with non-English characters in username. Check if it is the case.

If nothing works then you may use this direct link for manually installing this mod:

Report this bug to the game developers. Hopefully they will fix this issue with future updates.

1 Like

How did you implement the dismount on death on the new Elite model?

Hello there,
first of all I’d like to thank you for the amazing work.

I would like to ask you if it’s possible to add a couple of units to more civs, especially concerning the berbers. For them, the most out-of-context units on the field are the champion and the cavalier (and the HC to some extent).
I think you could definitely reuse the saracen infantry model you made for their champions too. Berbers surely had very similar infantry to the saracens, especially after muslims conquered them.
As for the cavalier it’s hard to say, but you made an ethiopian (or malian, forgot) cavalier which could be used, perhaps, in place of the usual cavalier.
The model there is a bit too subsaharian african-styled, but it will do better than a european full-plated knight.
Let me know of your thoughts.
thank you.

I am sorry for the late reply, I had been working on updating the mod to the new updated version. Also been working on some simpler non dataset mods - https://www.ageofempires.com/mods/details/3196/
Also I just added unique Mongol TCs and houses and was planning to expand the concept to Huns as well.

As for changing the Berbers I cannot do that in this mod, as you know I assigned unique models to each civilization without repetition to avoid confusion. You can easily mod that though as I just described on steam thread: https://steamcommunity.com/app/813780/discussions/0/1741134478138665327/?ctp=8#c1735510154208619165 to @Ioannes Bononiensis

Also there are some other good mods by devs like cinderybutton which you can check out, they try to replace more units by repeating the graphics.

1 Like

Hello, thanks for the reply.
Ioannes on Steam was me, but I was banned from the forums so I wrote here too.

I downloaded AGE and tried modding the units myself but I got nervous at the fact I could not find the units in the list after some time. Some were there, but the two I need weren’t. So I gave up, but thanks for giving me the tip on how to do it.
Perhaps in the future you will make more models, maybe less unique ones that more civs of the same ethnic group can share.

Rebuilt the mod on the latest version of the game. Just updated.
Also added new Mongolian Hussar and Burmese Elite Battle Elephant along with Yurt archirecture for Mongols and Huns.

Hey love your work so far but are there any units or unique heroes left you haven’t used yet?

Dagnajan (Elephant Archer with two riders)
Scythian Wild Woman (Lady who stabs with knife on attack)
Queen (Like the King unit it only has standing, walking and dying animation)
Tsar Konstantin (Triple horse Chariot with two riders)

Let me know if you discover I missed something…

Hello again,

I encountered today a problem with a saved game. Monks could be created but then “disappeared”. Their icon is also missing. The unit is not actually there, so it’s not invisible but doesn’t even create.
I’m not sure if this problem arose after I saved and closed then reopened the game later, but I noticed it as soon as I could make the monastery.
I also noticed another unit (not sure what it was for it was of the enemy AI) that was invisible. So in that case it did exist but could not be seen. I think it was a mounted unit cause my scout killed it and it made a neigh sound effect.
I also played on MP last night and this problem didn’t pop up so I think it was an occasional thing, maybe related to some game setting or whatever… just wanted you to know.

EDIT: as for CinderyButton’s mod, yeah I checked it but the way he/she applied the skins is out of my taste. For example, using an arab/byantine cataphract for the Berber’s cavalier is definitely not accurate, but much worse is the dismounted Konnik used as berber infantry.

EDIT 2: I tried recreating the error and this how it happens: if you save a game, and reopen it without closing the game, all is ok. However, if you save and close the game, then relaunch AoE2DE, the monk gets bugged as I described above.
Not sure if it’s civ-related. I used the italians in both tests.

1 Like

Yes the problem is a known issue in how the game manages the data mods. Let me explain you:

  • game runs on its own data set Aoe2DE data as default.
  • when you select a mod from the dropdown menu it’s data set is loaded in the background and the game runs on it.
  • when you restart the game, the game resets to original DE data set.
  • the game does not load the appropriate dataset for a saved game automatically. It just runs it on the data set running in background.
  • new/replaced units introduced by a mod will become invisible/revert to original for any savegame.

How can you fix this issue?

  • You can pre-load a game with dataset in a skirmish game and then load the saved game.
  • You can copy the files from mod directory to game directory and replace them to directly apply the mod.

This guy is raising the same issue for option to permanently activating a mod data set: