Multiplayer game command lags delays

Game Version: 101.101.35209.0

  • Build: 4667120)
  • Platform: Steam

Tentative Fix:

enabling V-sync, only works if game is quit, doesn’t take effect in-game during match via options.
This made a difference when trying two difference games, 3v3 populated with AI. Will try again with friends to see if this takes effect.

Issue:

While playing a 3v3 multiplayer (3 players vs 3 Moderate AI) on a Normal sized map a delay starts to appear between command clicks and actions being taken. Timed with a stopwatch as roughly 30 seconds by the 10min (game time 1.7x) mark, increasing to 8 minutes by the 56min (game time) mark.

During this issue units may be seen to move in slow-motion occasionally, the clock icon next to player names in the scores is blue 90% of the time, and notably the units do not unfreeze and speed up. Other players may not experience any delay/lag. Issue MAY be linked to which player created the lobby.
Game does not drop, quit, fully freeze, or disconnect.

Reproduction Steps:

  1. Have V-Sync disabled?
  2. Create private multiplayer game on eastus server (nearest).
  3. populate with 3v3 (tried with just me and rest AI, problem persisted).
  4. play game and watch in dismay as your commands are increasingly delayed.
  5. weep over your villager that fell to a boar.

Screenshot

Hardware:

Win 10 10.0.18363 Build 18363
Asus Zenbook UX433FA
CPU: i7-8565U
RAM: 16GB
Graphics: Intel UHD Graphics 620

AoE2 DE Settings:

1920x1080
V-sync off, all left-panel unchecked,
particles low, all right panel unchecked.
Benchmark: 1059.3

I created this Issue because although some posts seemed related the titles did not align with the keywords I naturally thought to search.

Related Posts:

The game has connection lag after a few minutes into the match, unlags, then freezes and disconnects in multiplayer

Online Game Speed Bug

16 Likes

And another thing:

Hitting F11 twice will bring up an overlay that shows FPS, Game time (and delay) and Ping.

Format:
T=xxx(+y) where xxx is in-game seconds and y appears to be your delay to game time.
L=xxx ms (a|b|c|d) where xxx is your ping, and abcd are your (?) deviation from L (current, avg, max, min)?
Looks something like that, those who know for sure please confirm how to interpret.

I’m adding this screenshot for information (aka, no it’s not the ping). As you can see in a relatively short time the in-game delay has accrued quite a lot already. This is enough for approx 15s delay between click and action (seems to be subject to the 1.7x scale).

5 Likes

Hey,

whenever my friend and me are playing a multiplayer game and one of us is hosting the game, we experience extreme lag. You click something and it takes minutes to react to it. We’re sitting next to each other and one sees the game 5 minutes ahead of the other one. Our PC’s stats shouldn’t be the problem, neither the internet connection, but whenever we join any other multiplayer game hosted by an other player, it’s fine.

Has anybody else experienced this? I would be grateful for any piece of advice or solutions!

6 Likes

I never had any issues playing before in 2019 or early january 2020, but I gave this game a couple of weeks to play some other games and I came back around feb 25th.
I tried playing a multiplayer 1v1 agains AI and got some random freezes and delay between commands which I found odd, since I would be the host and it was against AI, but the delay between commands wasn’t that bad.
Today I tried a couple more games against AI on multiplayer and I had like 5-10 minutes delay between commands, like WTF?
Even in dark age, I was trying to hunt some deer and my villagers cleared all of the deer without a mill. Later they came back and build 3 mills. I tried to pause the game and it showed “9 out of 10 pauses left” but it didn’t pause. I “played” for 5 more minutes and then it paused.
I really need help with this. Single player is normal

6 Likes

I’ve played another match today 1v1 against AI on multiplayer to watch the replay trying to get some answers…
It was all good, barely any delay between commands until at some point some of the AI villagers started being idle, and it was starting to pile up some delay. Then AI tried to send all the idle villagers to the same tree and they were all just bumping. I watched with AI point of view and it was cycling between 10 villagers trying to give them commands to chop/move and after that the game was unplayable with over 10 minutes delay between commands.
I had a couple of eagle scouts around and they were killing AI villagers under TC and the AI couldn’t even garisson. It was stuck in a loop or something. My 2 eagles cleared the base poking with 4 attack each vill until I left the game after almost one hour.
I’ll try again with HD and classic AI to see if this problem persists

edit:
HD version was the same or perhaps worse. Countless minutes between commands
CD version was much better, but still had some hiccups. Got something like 5 sec delay at some point, that reverted to 0 delay, but still playable. Maybe it was just a coincidence, or it was because CD version AI doesn’t make a lot of villagers

4 Likes

Same. Played BF Large map 4v4, lag is unbearable. Some units become completely unresponsive. Frame drops are also terrible.

I am on a:
Ryzen 3700
32GB RAM
GTX 950
M.2 SSD
Full fiber optic internet connection. with 150Mbps up and down.

3 Likes

The game is unplayable for this reason.

7 Likes

Same issue - unplayable and not fixed by game restart. Generally I will begin to experience 2-5 seconds command lag within the first 5 mins of play, and this will slowly creep up to multiple minutes by half an hour in.

4 Likes

I have same problem…When I host game against AI the game starts to lag, is not responding and the delay is larger and larger. It happens when I am alone against bots or when I am with friend against bots.
When I played with friend, the delay was like 10 minutes, it was unplayble.
Same happens for my friend when he hosts the game against bots.
It doesnt matter if other players are in game or not, host always has unplayable game. ABSOLUTELY UNPLAYABLE.
How can devs ignore this? It happens for other people, I believe the problem is quite common.

4 Likes

Same problem here. Single player is fine but multiplayer is completely unplayable. Hope there will be a fix soon. I bought that game to play with a friend during quarantine #covid19

4 Likes

I have found out (in my case) that it probably happens only in game with bots, I just played multiplayer with other people and it was without problem

3 Likes

Same here it happens mostly versus AI (we play 3v3 or 4v4, 4 humans-4 AI).

It is extremely annoying that we spent a total of around 100 euros and the game works horribly. and the fact is that in December it was working well!

Please fix thiiiis!

2 Likes

Same issues here. Freezes is not the big problem, the big problem is the game still continue when you freezing. You have more than 30s can’t control your unites after recover from the freeze. Well, 30s is enough to let AI clean your base.
I stop to play this game since this ■■■■ show up.

3 Likes

Same issues :’( … Help pls

3 Likes

Same experience here with the lag affecting the host of the game the most

2 Likes

After c.10 games played (attempted), 5 on multi PVP and 5 multi vs. AI, this only seems to affect vs. AI games.

3 Likes

Just played a game on local lan and by 15 minutes the game was essentially unplayable on the host machine (Ryzen 2600x). System resources were hardly being utilized and the network between both computers is gigabit, so it’s not a hardware issue.

4 Likes

Exact same happens for me but only when playing with my friend versus AIs on the nearest server. Sometimes it happens for my friend aswell. Never happened when playing multiplayer with unknown people wihtout AIs though.

2 Likes

Same here, both problems happen to me:

  1. Extreme lag
  2. Suddenly 1 player disconnects from the game

The devs are blaming the hardware…
Come on guys, at least say you’re trying to solve it, but blame devices?
That’s bad, I’m developer and that’s a very bad excuse.

FIX THIS, COMMUNITY IS REALLY BORED WITH THOSE BUGS

3 Likes

I am also getting a lot of lag. How do I control which server I connect to for ranked play? I’m in UAE and landing up playing against Australians? Makes no sense.

3 Likes