Performance issues on powerful hardware, constant fps drops

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.50292.0 0
  • GAME PLATFORM: Microsoft Store
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


Recently I upgraded my computer and to my surprise, the game is actually unplayable on MUCH stronger hardware, fps is constantly dropping and the game seems to freeze a bit every few seconds making the experience super annoying.

Old notebook:
i7-3630QM thermal throttling hard
GT 650M 2GB
16 GB Ram

New desktop:
Ryzen 5 5600X
RX 470 4 GB
16 GB Ram

Both the machines on the same settings, same map, same single-player match, everything the same (none of this matters, the issue happens in any combination of settings and map), the old machine runs fine (kind of laggy, but fine) at around 30 to 50 fps, the new machine quickly jumps to 60 fps but goes full stutter from there.

Now, this is my theory, I’m no expert or anything but comparing to other games and doing some educated guesses…

The old machine never reaches the fps cap because of thermal throttling, thus keeping a constant load on the gpu, even tho the frame rates are lower the experience is much better because there are no huge dips.

This is probably due to the FPS cap (“vsync”) not being able to catch up to fps drops fast enough, making it drop too much before putting any load on the gpu again, its the same horrible code used on Minecraft to limit FPS, even with vsync disabled the cap still happens and makes the game unplayable.

If that is the case, it could be easily solved by making vsync enabled by default, thus “fixing” that issue of using too much power but still allowing who wants to disable it and unlocking all the performance, or allow us to manually choose at which frame rate the cap should happen, giving enough room for the drops to be unnoticeable.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Open the game
  2. Start a single player match, map: mitch, 4 players, 2 teams, 500 pop cap, random civs.
  3. Test your patience.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Smooth gameplay, without fps drops.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

This is just to demonstrate the gpu usage and fps drops, early in the game with very few units, just moving the screen around

Ryzen fps counter: Ryzen - YouTube (soo many pixels)
Old i7 fps counter: Core i7 - YouTube

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

No need , any game this will happen.

1 Like

Here you go:

I have an rx470 and a ryzen 7 3700x also by the way.
Try to use RTSS to show your frametimes, but get rid of vsync first.
Does it get better temporarly, if you hit alt-enter 2 times to toggle windowed and fullscreen again?


Nothing I do allows me to actually disable vsync, it’s always stuck at 60 fps. Alt-enter does not help, nor changing settings, resolution…

Frame times are always at 16.8 ms but with several random spikes… something I noticed is that later in the game when everyone is at population limit and the performance starts to degrade the issue kind of gets better as the game can no longer maintain a steady 60 fps just like in the old system.

RX 470 frame times:

GT 650M frame times are all over the place but at a steady average.


Did you enable Radeon EnhancedSync for the game?
Do you use a FreeSync compatible monitor?

I had the same issue, but I fixed it, see my vsync bug report.
My game was stuck to 75fps and it was so much worse to now, when my fps are uncapped.
What I was not able to figure out/fix is the frametime bug, which causes extrem stutter for me.

On arabia, 1v1 vs ai, tiny map, you should have 300fps or more in dark age.
If you are not capped, that is.

1 Like

Weird, while messing with the EnhancedSync to see if I could unlock the fps (which I couldn’t) the issue disappeared for a moment, so yes if I alt-enter it gets better for a little bit but not every time, if I toggle that EnhancedSync option or the Image Sharpening a bunch of times it also temporarily fix the issue.

I dont have FreeSync btw

1st: Open the game and set the graphic options to the following:

Ingame Settings

2nd: Close the game and open your Radeon Software.
3rd: Update the Radeon Software.
4th: In Settings/System make a factory reset.
5th: In Settings/Graphics chose the “Standard” profile. Don’t touch anything else!
6th: Start the game and play a few minutes, then close the game.
7th: In Gaming, click on the Age of Empires 2 Def Edition Tile and set everything to the following:

Driver Settings for Definitive Editon

8th: Start the game and wait in main menu until RTSS shows up.
9th: Start an arabia 1v1 against the default ai on a tiny map. RTSS should show you more than 200 fps now.

I hope this helps :stuck_out_tongue:

My remaining driver settings are below, but try out to stick to the standard profile first and go through all steps, before changing something there!
Also make sure you haven’t set an fps limit in RTSS or a similar program.

General driver settings


Thank you very much for these 2 pictures!
I had the suspicion that it is a Radeon specific bug, because it is so severe that the devs would have noticed it.
They probably use Nvidia or Intel.
You can clearly see that you have exactly the frametime from the 60fps limiter (16.7ms) for the most part, but some framestimes are just super high and cause the stutter.

edit: The fps cap and the stutter may not be necessarily related. I have uncapped fps, but I get the frametime spikes. When I change my display mode (e.g. by pressing alt-enter 2 times) I have perfectly flat frametimes again, of 10ms or less. I guess it is because some part of the rendering is reinitialized.
But I can’t profile and debug the program as an end user.

It can also be a Ryzen CPU thing, maybe I get to test on a different CPU soon.

FPS were capped like 4 updates ago, cause several players were complaining about over heating, specially those on mobile hardware, there is a trick to force to skip the vsync but it is actually not recommended, 300 fps while luring boar and deers but 45-50 fps in a 4x4 180+pop each one and fps decreases more when 200 pop each and trade carts, no matter the hardware you have the game can’t keep steady frame times with larger populations and a lot of path finding calculations.

Having explained that, the only thing that you could do to improve it a little is by manually set affinity to the physical cores lets say core 0 and 2, game drops a little when running in the virtual threads being SMT from amd or hyper threading from intel, but still the game suffers a lot to keep perfect frame times cause it runs all the calculation in one core and the code is too old that path finding calculations hurts the performance a lot.

I tried those exact settings but no success, I read somewhere around here that it is intended to be hard limited to the monitor refresh rate.

Thats the thing, I understand the performance to degrade as the game progresses, my issue is that the performance is awful at early game with no more than 5 villagers, it actualy gets better later on when is no longer reaching the fps cap due to the issues you described, even tho the fps is lower it is steady, no huge dips.

1 Like

Then what is the trick?
My game runs much better with 300fps, than with 75fps! But he is not able to unlimit.

What you write is not specific to our problems.
He has a pc with 2x more computation power on the CPU, both singlecore and multicore, and x6 on the GPU, yet the game runs worse, because it shows a certain bug!
We have the lag from dark age onwards, sometimes. It is self explanatory that the fps decrease with a higher count of units in the game.

I will check if SMT or process affinity can change something, tho.

edit: Disabling SMT and/or assigning the game to certain cpus didn’t improve anything for me. I tested out various settings. I used launch commands similar to this:

C:\Windows\System32\cmd.exe /c start “test” /Normal /affinity 20 “C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\AoE2DE_s.exe”

For me the issue has been fixed in the last update, no more random drops and stutter, gameplay was as smooth as it can be, the usual performance drop when everyone is at 500 population cap even tho there is plenty of hardware available but the game was totally playable, even on scenarios where it used to be really bad with hundreds of units stuck somewhere, AI seems to have improved as well, just lost a hardcore 2x2 and that didn’t happen in a while. Thumbs up for the devs.

I still have exactly the same problem.

1 Like

weird, look at my frame times now:

I disable the Radeon overlay and I am using the new driver 21.8.1, and windows 10 also updated, but I still had the issue prior to this latest update.

1 Like

I have exactly the same problem.

In dark age I also have the normal, constantly low frametimes, but for me it will change suddenly and randomly. Just leave the graph on, while playing a few matches. You will see immediatly, if the problem occurs.

I will update my driver.

Edit: I still have the same:

1 Like

I recorded this for other purposes, but you can see how choppy it was and right at the beginning there is a random drop. That used to happen from start all the way to the end of the game.

Look at how it is today:

Hardware is still the exact same, other than normal windows/drivers updates (which I didn’t do anything manually) everything is the same.

Edit: Just want to make it clear these clips are not a representation of the issue I described in this post, I had frame drops starting from 1 second in the game but I never actually recorded the actual gameplay just took screenshots of the frame graphics, I had that random clip I sent to a friend to show how bad it was running on my computer, it is just to represent that it got better even on the challenging stages of the game, for now is running smoothly from start to the end of the game.

Wait! It says for me, that the most recet driver is 21.6.1! Maybe my GPU (RX470) is too old.
I will take a look again.