Performance Problem (low FPS) in late game multiplayer, yellow or red clock

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: all versions since 1 Year
  • GAME PLATFORM: BOTH Steam / Microsoft Store
  • OPERATING SYSTEM: Windows 10 / 8GB MSI Radeon RX 5500 XT / AMD Ryzen 5 3600 6x 3.60GHz /1000GB Kingston SA2000M8/1000G M.2 2280 PCIe 3.0

:arrow_forward: ISSUE EXPERIENCED

In Multiplayer games (ranked and normal), there are often other players who gets a yellow or red clock during the game. I think its because of their low benchmarks. The higher the Pop and the Ages go, the more often they get yellow Clocks and the worse gets the performance on my PC. My Benchmark shows 1250, my GPU and CPU usage is always under 50% usage, and it shows 120fps, but on the end, i have not more than 5 fps. Its unplayable.

Since I started playing AOE 2 DE in November 2020 , I have this unresolved performance bug. In result, I have to continue with AOE 2 HD Version with my friends every evening. I tried very much to solve this, like install on a new windows 10 on a new bought SSD, without any other software on it. Nothing helped. Please, help us!

Here is a example video of a game of me.

It seems, that many others have the same problem as I have. Look at these posts:

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. open a multiplayer game 3v3 4v4
  2. play until castle age with anyone with a yellow clock
  3. see that its no fun playing now…

:arrow_forward: EXPECTED RESULT

Maybe I can play without performance ishues, although other players have bad benchmarks.
Otherwise a solution could be, to let only players with a high benchmark (1150) play ranked matches.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

For AMD graphics user there is not solution except hitting alt-enter all the time to reinitialize some of the rendering by going window mode to fullscreen.

You should have bought Nvidia graphics man!

1 Like

What are you talking about, i have used 3 radeon cards on this game and not a single issue, don’t generalize ur issues on ur end.

Red clock is tied to cpu lag, maybe overload or over heating.

There is already a benchmark threshold to be able to play ranked. I have a benchmark of about 980 and I’m only allowed to play 1vs1 ranked. You need 1000 to be allowed to play TG. So increasing this threshold should be easy if one want to do this.

Thanks for this report, we are currently tracking this issue!


yup, this happens pretty often. cant micro, cant play

1 Like

Problem not solved yet… its nothing about the vsync.
Hope the Dev can help anyhow.

1 Like

This is happening to so many people. There’s been years of incompatibility with 2DE and AMD users, nothing has improved yet :frowning:

1 Like

I have the same problem, don’t matter which setup I use. Hate the developers and want my money back… not playable but the money got taken.

1 Like