Units struggle to load into Transport ships

Game Version:

  • Build 35199
  • Steam version

Issue:

It is frequent for units to have pathfinding problems to load into Transport ships, even when there is a clear path ahead them and no obstruction of any kind.

Reproduction Steps:

Order one or more units to load into a Transport ship and observe their behavior.

The villagers on the shot that follows where stumbling on each other when commanded to enter the Transport ship, preventing one other to embark.

Even being alone and with a clear path to the ship, this villager was refusing to enter it.

3 Likes

Thank you for the report; I’ve written this up for the team to investigate!

I don’t suppose you have a recorded game of the mission where you experienced this issue? That would be immensely helpful in narrowing down the root cause of the issue.

Thanks again!

3 Likes

That bug exists since the version from 1997.

4 Likes

I tried to replicate the issue and only seems to happen with Light Transport (not Heavy Transport). I’ll post a GIF if I can.

2 Likes

Unfortunately I haven’t a recorded game of this mission, but I remember that it was the one from the Yamato campaign where the player needs to tribute gold for the red enemy faction in order to prevent being attacked, while looking for a suitable place to establish a new base on the other side of the river, where the yellow faction allied to the player is established.

Please, also take note from these following other bugs I have reported already:

Thanks for the efforts to keep the game running smoothly!

1 Like

Interesting, I haven’t ever noticed that, but now that you mentioned it I believe you are right!

1 Like