List of unfixed bugs

I’ve extensively tried things to locate a root cause for crashes I receive fairly early and frequently since patch and the only thing I can determine is that(for me) the crash will not occur if no units are moving around no matter how many units there are, but even one unit like a scout walking around constantly will eventually trigger a crash fairly quickly - I can crash the game in <5 minutes by only moving a scout around but I can create 40-50 villagers and just leave the game turned on and it won’t crash in >2 hours

Prior to a crash I do not have high cpu/gpu usage at any point and do not stutter or lag, and it occurs in multiplayer & singleplayer no matter if the units moving are mine or someone else’s(tested in skirmish singleplayer with no opponents and infinite resources so as to create large amounts of villagers without excessive walking around)


Perhaps the update to new pathing broke the game? every time I leave scout on auto-scout and by the time 3/4 the map is uncovered it crashes me. Combat is fine can fight and whatnot in certain scenarios but scouting seems to be the key

1 Like

Pretty much observed same thing, I actually used the autoscout to see if it was crashing because of the right clicks when ordering units to move, but it behaves exactly the same if you tell them to walk somewhere or if you set it to autoscout, I also tested if it is when you reveal unexplored map/fog of war but it behaves the same on an all-visible start as on a normal start - it’s probably connected to the pathing somehow, maybe when they try to avoid an obstacle or that new pathing fix for determining the best route within 20 tiles? It might be getting stuck into an infinite loop trying to figure out what the best route is in some circumstances

1 Like

Hopefully we can get this resolved ASAP want to enjoy as much as I can before the EMP :smiley:

1 Like

Editor Bug: Chinese spawn +3 vils, every time you load a scenario with them in the editor.

1 Like

Guys stop posting random bugs in here…this is just a collection overview, make a single topic for it where you describe your problem.


Yes, exactly, thanks for writing that.

If you want to report a never before seen bug, first make a bug report thread, and then you may ask me to share it here by providing a link.

1 Like

I made a bug report about that for patch 43210. Save game browser taking a long time to load

1 Like

OKAY! Let’s see what we can do with this list! First, a few notes:

  • Thanks to everyone who has taken the time to start or contribute to a separate discussion thread with details about the problem. Your efforts are invaluable in identifying and fixing bugs, and your time and effort is MOST appreciated!
  • Thanks to @Harooooo1 for compiling the thread! Having a priority list of issues is helpful in making sure we know what’s important to you.
  • If anything ISN’T on track to be fixed, it’s likely missing context. When you come across an issue, explaining exactly when, why, and how it happens is CRITICAL to our ability to reproduce and fix the issue. If we can’t reproduce a problem ourselves, it’s MUCH more difficult to identify and implement a solution—particularly if it only impacts a small subset of players.

I’ve spent the last day going over all the issues and vetting them against our database of issues. Here are the brief results of that investigation:


These are issues which are “solved” internally and have a fix in the works. They may still need to undergo extensive testing before they are committed to a game build, but we are looking to fix some of the most severe issues as soon as we’re able!

Coustillier charge damage is done twice to CA armor class (to all Archers it seems, not just CA)
Number of crashes increased since January DLC patch
Out of Sync started happening since January DLC patch
Diagonal gates can’t be built upon by a villager, from some specific angles
Possible to place and build a Castle foundation inside another Castle’s foundation if that Castle’s foundation is out of sight - Video
Building town center over existing foundation that is out of LOS (same thing as above but for Town Centers, seems to happen to all larger building foundations)
Korean Turtle Ships damage is way off/random
Update 44725 achievement bug
Techtree shows wrong unit names & tooltips (Genoese xbow written as War Wagon
[MERGED] Health Points not showing properly in tech tree
Watching replay of Gajah Mada mission 2 desyncs the replay at 3:15 every time
Defeated Players can Ungarrison Units in DE


These are issues that have tracking tasks written up, but which may still require investigation. These may still require more information or may not be an issue

Too much units with AI pathing causes lag - #5 by thieftdp8498

@thieftdp8498 has provided a lot of valuable information in the linked discussion thread. These details have been passed along to the team, who have not been able to reproduce this internally (thus far).

Skirmishers don’t provide extra arrows when garrisoned (due to new Mayan UT and legacy bug of chu ko nus and kipchak giving too low dmg to garrisoned building)

The description of how the damage is calculated (and affects different units) is INCREDIBLY useful! All of this has been added to our internal tracking task.

Shift-move after shift-attack is bugged
After using “Attack move” command, units sometimes bug out and stop fighting (will make report soon)
Random civ not working as advertised - can give duplicate civilization in ranked
[BUG] Font doesn’t look very good, even at big UI (125%). And pixel artifacts throughout the game
Game won’t stop re-subscribing to and activating event mods
Restore function shows wrong civ for every non-ai player + inactive AI
Campaign: Bari - Mission 4 - Relics Stuck in Mountains
In-game chat not visible for spectating live games (will make report if no one did yet)

This is a long-standing ask. For now, it should be considered “by design," but the desire is well-noted!

Your units instantly disappear if you try garrisoning into an enemy battering ram in Treaty Mode
Tatar sheeps from new bonus don’t spawn in Campaigns or custom Scenarios
tech tree says Bulgarian 50% stone discount on Town Centers starts in castle age, but in gameplay the discount works in Dark Age too
Lobby browser resets filters when switching to Spectate Games browser
Hotkey doesn’t work for the King’s Follow command(regicide)
Monks tasked to a relic stops moving after right clicking to a random location (legacy bug)
Castle/Town Center/Krepost/Harbor/Donjon losing attack focus after creating unit (legacy bug)
Blast attack levels not working as intended for modding
Resource 210 (Reveal Relics) not firing after the start of the game
Mod doesn’t update version when joining lobby
The pierce armor in the Scenario Editor shows the value of the unit’s melee armor
Map Editor: Set player visibility not working for P1
Lots of crashing while using Layering mode in Scenario Editor
Water in scenario editor doesn’t render properly
[BUG] [Scenario Editor] Modify Attribute Effect not removing visual glow from heroes/not adding visual glow to units
Map displaying completely black ground under units and buildings when a unit or building is selected to move in editor mode
XS script does not accept non-ASCII chars in strings
Game crashes and becomes slower if replace a normal soldier with an [Invisible Object] in Editor
Game crashes when tried to crazily click at “Delete Trigger” button to delete some triggers


Serjeant pathfinding/agro bug when placing donjon

When a unit is unable to reach their construction project or comes under attack, they will turn to defend themselves. While there may be an issue here, we will need to find a balance between the indended design of the game and

Technology hotkeys at the 2nd Dock page are bugged and don’t work if using them from the 1st page

If we allow this, then we could have two techs on two different pages using the same hotkey, which would probably cause more confusion. Unless you feel strongly about this and have an optimal solution, this is unlikely to change.

Elite Steppe Lancer and Elite Battle Elephant Research icons overlap

According to the team, there is unfortunately no slot where one of the upgrade buttons could be moved: slot 13 used by Tarkans in scenario full tech tree games as Huns, and the fifth column is reserved for operation buttons. As such, it was decided to leave them on the same slot, since it doesn’t stop the research of both upgrades if there are more than one stable.


There isn’t enough information for me to understand or write up the issue. If there is not an active thread, it may be wise to create a new thread while linking the old discussion on the topic.

Villagers still bump into each other

Without the context provided by a replay file or a link to more discussion and information, there’s not much we can do based on the report alone! We’d absolutely love to hear more about when and where this is happening.

Spectating recorded games can desync when turning on fog of war

As with above, this will require additional details to narrow down the cause. While the team is investigating reports of out-of-sync errors when spectating a game or reviewing a recording, more specific information will help them as they dig into the issue.

Defensive building still prioritize enemy buildings over units! (not quite sure if it’s still occurring or not, need to check)

Re-opened our tracking task for investigation. Certainly keep us updated with more details where possible so we can fully understand the behavior being experienced. (Replay files and videos are especially helpful!)

Shift queue attacking with melee units is broken

Ticket has been written up for investigation, but may require more information to highlight the severity of the issue. If this impacts anyone’s gameplay, I recommend they weigh into the thread linked above!

Two players can be assigned the same color in lobby games, and they will not be in CO OP mode

There have been several reports of this issue, but no reliable repro internally. Until we can determine when and why this is happening, we’ll have trouble fixing it. (Replay files, player names, match ID’s, and other details may be useful.)

Farm texture sometimes disappears while villager is working on it - the farm becomes unclickable, making it impossible to re-task a villager back to the farm if the villager was interrupted

A task has been open for some time, but the issue is not easily reproducible for our team. Replay and dxdiag files would be most helpful in seeing whether this is an issue with the game, or how the game interacts with certain hardware.

General Overlay Freezes

Test is unable to reproduce the issue. This is likely hardware related, so any future reports should include a copy of the player’s dxdiag file and a video highlighting the issue and steps leading up to it.

Description of Byzantine Fire Ship attack speed bonus was incorrectly changed

Is this still the case?

Saves/Replays menu can sometimes take a lot of time to load, and sometimes displays wrong civs (will make bug report if no one did yet)

Need more information if this is the case. Note that the Civ display issue is already logged separately.

Bug: In-game score panel is collapsed after watching recorded game

Unable to reproduce in the latest builds. Additional information / video evidence will help us better understand what is being reported.

Name changed to “SinglePlayer” after resigning and restarting

Is this still the case?

Lobby browser doesn’t show all the hosted games, and the search is slow/unresponsive (will make bug report)

More information is better! This is something that is well-known, and improvements are always being made to improve the experience.

Villagers chased by boars will stop and fight if tasked to a different resource (legacy bug)

Is this still the case? Several improvements have been made in previous builds, so an updated report with examples would be most welcome!

Resource 210 (Reveal Relics) reveals the whole line of sight instead of just the unit

Additional information requested by the team.

Weird Interface Bug

Could use additional information to clarify the issue for the team.

Timers broken in scenario editor

Is this still an issue, or did the workaround offered by @ShadowProsPL address the issue?


These issues need additional investigation, or it needs to be clarify the design intent of the reference behavior:

Modding the pop limit over 500 doesn’t work in Standard Games
Secondary projectiles behave weirdly when accuracy of a unit is set to 0%


At this point: if any new issues crop up—or if any old issues rear their heads again—I’d recommend spinning up a new thread to track those issues and ensure that old problems (which may have already been fixed) don’t keep getting dragged along. A quarterly thread would be an AWESOME way to help us stay on top of what is relevant and ensure your concerns are being addressed in a timely manner.

Thanks again for your work, and I hope this provides some insight into where we’re at! :+1:


It’s not only the shift queue attacking, but also right click attacking. You have to put units on stand ground, otherwise they just ignore your command and attack nearest target. How is this not impacting gameplay? This is not a thing before DE!

Look at Hera’s demo again. Stand ground is just a compromise.

1 Like

@GMEvangelos , some people reported that game is working a bit better for them if they turn all of their CPU cores except one, and then game can work, but with lag. So, I hope team can investigate why in some cases game is only using one CPU core instead of all. That may even be a reason of high CPU/GPU in Menu and In game (Even though i still belive there are some issues with bad coding of the game). If dxdiag is needed from those users that had issues, I will send you them in PM.

1 Like

@GMEvangelos , @PilgrimHYR , here is the YT video of a guy that made fun of “Improved patting” and recorded it yesteday. Yes, issue is still happening, less frequent then before, but it still happens. Also, there is a video of vills taking a long walk to a resource, even though shorter path is available. I will try and find that clip as well.


LMAO villager enjoying the improved pathing with 2min straight of dancing! Nice music :rofl:


@GMEvangelos , @PilgrimHYR , here is the link to a thread that has a video with Villager going really long distance instead short distance.


In the tech tree for the Slavs the UTs have the wrong description for some people. I’m playing with 2 friends and for me and one of the others it shows the description for Sultans and not for Orthodoxy and Druzhina.

Make a report, and you might want to merge it with this one:

@GMEvangelos - Thank you for the updates on all of those :slight_smile: The “104 chat command not working” issue was mentioned above, but didn’t get included in the OP or your update, that I can see…


Thank you for the response. I am glad the list is addressed by someone official, and useful to you.

I am planning to make a big revision of the list this weekend, to check if each of the long standing bugs is still occuring.


It sure is, the campaigns are hard to play without save-games and I would like to see it fixed as soon as possible.